0
Welcome Guest! Login
0 items Join Now

Re: GANTRY ADMIN - troubleshooting tips

  • Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 7 years 1 month ago
    • Hi Kat,

      Thanks for getting back to me. I'd be happy to do a test install but where should I do it - it would destroy my previous work if I used rocket launcher in the same directory, wouldn't it?

      Also, just so you know, the site was up and running fine for a year and a half before this guy changed the time zone.

      Thanks a lot,
      Seth
    • ka3media's Avatar
    • ka3media
    • Rocketeer
    • Posts: 88
    • Thanks: 1

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 7 years 1 month ago
    • @ Kat

      Thank you for your reply... that was going to be the next thing coming if there is any spare time ;))

      I thought there would be some experiences right now with this...

      @ Serh:

      Hi Seth, login via FTP on your webspace. create a new directory. Then login to your domain-hoster / webhoster und create a new subdomain like "v2.yourdomain.com" and point it to the new directory.

      !!!!Create a new database @ your webhoster!!!!

      Upload the rocketlauncher as a zip, fastest way is to upload it complete as zip and use akeeba kickstart ( www.akeebabackup.com )

      Kickstart is great also for installing a standard joomla installation :)

      Then use "v2.yourdomain.com" as standard domain for all actions.... and there you go
  • Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 7 years 1 month ago
    • www.nonumber.nl/ has some great plugins although the "admin bar docker" kills Gantry. Glad to have this one issue fixed.
      I can't even begin to figure out what caused this. It happened on the last version of my site and I couldn't figure it out. I had to rebuild the whole thing. NOW it has happened again.

      Does ANYONE have any idea why I would loose control over my Gantry settings? Take a close look at the first photo. What's wrong with this picture?

      The images explain the problem in detail.

      The second photo is a screenshot of my plugins ordered by activation, the 3rd alphabetized..

      Any ideas on which ones I should be turning off first to test it? This is maddening.
      It's been so long since I've looked at the template settings and I've installed many a plugin, it would just drive me mad to simply start turning off one at a time and then refreshing the page. Reactive, then turn off another, then refresh, then ...you know what I mean. And it's after 9pm here. Time for bed.

      pocketchalker.com.previewdns.com/gantry.png
      pocketchalker.com.previewdns.com/plugins.png
      pocketchalker.com.previewdns.com/plugins_alphabetized.png

      I could use some help on this and would love to wake up to some suggestions on which plugins to kill first.

      Thanks in advance.

      Doug

      ps. Posted a new topic on this also. Hope I didn't break too big a rule posting it here also.

    • Last Edit: 7 years 1 month ago by MalaCzarna.
    • Newbie who's not so new...just slow on the know.
      AND Yes, I read the Top Tips for Support and YES, it helps get results!!!
      Links and screenshots get results!! Try It!!!
      After reading some of the replies and people not paying attention to what is asked of them...I would like to promote this whole...
    • ka3media's Avatar
    • ka3media
    • Rocketeer
    • Posts: 88
    • Thanks: 1

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 7 years 1 month ago
    • ka3media wrote:
      Hello

      i figure out a problem using gantry with the Template "Quantive" version (1.5.5).

      It works fine with Gantry version 3.0.11, all up from 3.1.x it is not possible to work with the template admin, no feature can be set....

      i checked all given tips, everything is configured right!

      BUT: I use customized database prefix. Could this be a problem for Gantry from 3.1.X

      Thank you for your support :)

      I figured it out! I used a small little admin module called "session timer", that shows the remaining session time. And this causes conflicts with gantry admin... so, kick out and it works :)
    • Stephen's Avatar
    • Stephen
    • Jr. Rocketeer
    • Posts: 27
    • Thanks: 0

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 11 months ago
    • Hi all,
      I hope you can help me.

      I have trying to get the Zephyr theme installed for a day now. However I am having all sorts of issues.
      I have even tried to install another theme and it just doesn't work.

      I have done a trail on my local system with a 2009 template which worked fine. Not one issue.

      I have been through this entire post and made the recommended changes. however I STILL am getting these errors and I am unable to work it out.

      Another thing: when the files are chod to 755 on folders I still comes up with "unwriteable" only when I change it to 777 do they become writable.

      These are the errors I am getting.
      Menus: Cannot assign default template.
      Parameters The parameter file /templates/rt_zephyr_j15/params.ini is writable!

      Warning: mkdir() [function.mkdir]: Permission denied in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 215

      Warning: chmod() [function.chmod]: Operation not permitted in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 216

      Fatal error: Uncaught exception 'CacheException' with message 'Unable to use given directory. Check file permissions.' in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php:50 Stack trace: #0 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(73): FileCacheDriver->__construct(900, '/home/mysite/p...') #1 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(59): GantryCache->init(true) #2 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(50): GantryCache->__construct(true) #3 /home/mysite/public_html/components/com_gantry/gantry.php(168): GantryCache::getInstance(true) #4 /home/mysite/public_html/components/com_gantry/admin/elements/gantry.php(54): require_once('/home/mysite/p...') #5 /home/mysite/public_html/libraries/joomla/html/parameter/element.php(76): JElementGantry->fetchElement('', 'coresettings, p...', Object(JSimpleXMLElement), 'params') #6 /home/mysite/public_html in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 50

      Can someone please let me know how I can fix these.

      Note: mysite is not the real name of the site.
      Cheers.
    • brtideas's Avatar
    • brtideas
    • Jr. Rocketeer
    • Posts: 22
    • Thanks: 0

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 11 months ago
    • Hi:

      I have tried to install Gantry a couple of times and have absolutely no luck.....I would really like to use one of the newer templates on my site rebuild, but it requires that danged difficult to use Gantry and it's not working & have no idea why.....

      Reading the troubleshooting tips above, I see that #3 might be my problem, but above, it gives no information about how to change that setting. Can you help me with that?

      Thanks,

      Amy Blain
  • Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 10 months ago
    • aikicoops wrote:
      Hi all,
      I hope you can help me.

      I have trying to get the Zephyr theme installed for a day now. However I am having all sorts of issues.
      I have even tried to install another theme and it just doesn't work.

      I have done a trail on my local system with a 2009 template which worked fine. Not one issue.

      I have been through this entire post and made the recommended changes. however I STILL am getting these errors and I am unable to work it out.

      Another thing: when the files are chod to 755 on folders I still comes up with "unwriteable" only when I change it to 777 do they become writable.

      These are the errors I am getting.
      Menus: Cannot assign default template.
      Parameters The parameter file /templates/rt_zephyr_j15/params.ini is writable!

      Warning: mkdir() [function.mkdir]: Permission denied in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 215

      Warning: chmod() [function.chmod]: Operation not permitted in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 216

      Fatal error: Uncaught exception 'CacheException' with message 'Unable to use given directory. Check file permissions.' in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php:50 Stack trace: #0 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(73): FileCacheDriver->__construct(900, '/home/mysite/p...') #1 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(59): GantryCache->init(true) #2 /home/mysite/public_html/components/com_gantry/core/utilities/gantrycache.class.php(50): GantryCache->__construct(true) #3 /home/mysite/public_html/components/com_gantry/gantry.php(168): GantryCache::getInstance(true) #4 /home/mysite/public_html/components/com_gantry/admin/elements/gantry.php(54): require_once('/home/mysite/p...') #5 /home/mysite/public_html/libraries/joomla/html/parameter/element.php(76): JElementGantry->fetchElement('', 'coresettings, p...', Object(JSimpleXMLElement), 'params') #6 /home/mysite/public_html in /home/mysite/public_html/components/com_gantry/core/utilities/cache/fileCacheDriver.class.php on line 50

      Can someone please let me know how I can fix these.

      Note: mysite is not the real name of the site.
      Cheers.

      If you are experiencing the issue above it is likely due to this folder not being able to be created (so you need to create it manually and set permissions to 777):
      administrator/cache/_gantry-3.2.1

      I think it would probably be better if the RocketTheme code made use of the JFolder/JFile classes in order to make things more compatible with various servers in this case as it is completely unclear which folder was causing the issue (I was simply receiving a 500 error when trying to get to edit view for the template).

      Additional notes: This is for Gantry 3.2.1 obviously for my example (I guess the folder name changes between versions, which would cause an issue upon upgrade) and I'm using Joomla 1.6 (unfortunately, my server environment isn't one where PHP gets run as the user, so normally everything would get created as Apache so I need to make use of the FTP Layer and this is not being used in the file cache driver file from Gantry to create that folder).
    • mpeirce's Avatar
    • mpeirce
    • Newbie
    • Posts: 2
    • Thanks: 0

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 10 months ago
    • Hi - has anyone gotten back to you regarding your 'permissions denied' issue? I've got the same issue where I see all of my directories are unwritable as well as the configuration file. I don't want to set them to 777 and open it up to the world and am wondering if there is a better solution.

      Thank you,
      Mike
    • mpeirce's Avatar
    • mpeirce
    • Newbie
    • Posts: 2
    • Thanks: 0

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 10 months ago
    • Hi - has anyone gotten back to you regarding your 'permissions denied' issue? I've got the same issue where I see all of my directories are unwritable as well as the configuration file. I don't want to set them to 777 and open it up to the world and am wondering if there is a better solution.

      Thank you,
      Mike
    • Kat05's Avatar
    • Kat05
    • Preeminent Rocketeer
    • Posts: 25785
    • Thanks: 291

    Re: Re: GANTRY ADMIN - troubleshooting tips

    Posted 6 years 10 months ago
    • brtideas wrote:
      Reading the troubleshooting tips above, I see that #3 might be my problem, but above, it gives no information about how to change that setting. Can you help me with that?

      Thanks,

      Amy Blain
      hi amy,

      please contact your host for assistance with this setting.

      kat :)
    • Kat05 / QA Lead & Support / Germany

Time to create page: 0.134 seconds