0
Welcome Guest! Login
0 items Join Now

url's in menu-items are randomly messed up

  • url's in menu-items are randomly messed up

    Posted 5 months 1 week ago
    • Hi, This site: www.centrumvoorurologie.nl is based on Gantry (v4.1.34) and RT_Acacia template (version 1.11) and Joomla 3.8.2. The sites uses SSL/HTTPS.

      For months now I have the problem that url's are messed up, randomly. For example, an url in the main-menu points to:
      zxcv.centrumvoorurologie.nl/xxx/xxx
      or www.t.centrumvoorurologie.nl/xxx/xxx
      or www.m.centrumvoorurologie.nl/xxx/xxx

      Off course, the url's avobe point to non-existing pages.

      This happens intermittently and sometimes even occurs when you refresh a page. Also from wrong url's to correct url's when you refresh the page (Ctrl-R). This happens only at url's from menu-items, never on url-links in text, modules etc. And both from the Main-menu at the top, as the website-menu at the bottom.

      Of the course the correct url should be: www.centrumvoorurologie.nl/xxx/xxx

      Can this problem be caused by your extension RokNavMenu? Where should I look for solving this strange problem? I've checked:
      .htaccess
      Cache-extensions
      PHP-settings
      System Check from RS!Firewall
      Completely reinstalled Joomla!CMS from a install-package (Copied all Joomla-files over the existing files)

      The site is very good secured by 2FA, RS!Firewall, Admintools, etc. I've never seen this in other Joomla-sites...

      Thanks, Gerard Verheij, The Netherlands
    • Last Edit: 5 months 1 week ago by GF Verheij.
    • MrT's Avatar
    • MrT
    • Preeminent Rocketeer
    • Posts: 76002
    • Thanks: 9309
    • Web Designer/Developer

    Re: url's in menu-items are randomly messed up

    Posted 5 months 1 week ago
    • Please do not post extensions/template specific questions in the "Free Stuff" forum. You should post in the extension forum or template forum as appropriate. Most of these forums are for members who have a current PAID membership. Our priority is always to assist paying members.

      Thank you for your understanding.

      Your subscription appears to have expired. Support does require a current subscription.



      Are you using a CDN? (e.g. cloudflare) that go do things like this so turn it off

      Turn off "system - page cache plugin" and clear server cache.

      Does clearing cache resolve the issue?

      It won't be caused by roknavmenu. It good be htaccess but I doubt it. It's more likely a caching issue or possible a SEF extension (e.g. sh404sef?).

      Make sure everything is on the latest versions too.

      Regards, Mark.
    • Please search forums before posting. Please make sure your post includes the version of the CMS you are using and a link to the problem. Annotations on screenshots can also be helpful to explain problems/goals. Please use the "secure" tab for confidential information.

Time to create page: 0.058 seconds